As some of you may have noticed yesterday our shared hosting servers had a major upgrade. We had been running PHP 5.2 for quite some time for the backwards compatability of our customers and some older sites. For instance most Joomla's 1.5 and before and most Wordpresses from a couple years ago still have to have PHP 5.2 to run.

Unfortunately running this old of a PHP version was no longer an option as PHP officially dropped support for it last year and now PHP 5.3 is also EOL and Deprecated. Seeing as two versions have been upgraded since 5.2 we had no alternative but to upgrade it.

This is for the security and increased support of our customers. There were quite a lot of security holes found in 5.2, those customers that use 5.4 on our servers now will have the added knowledge that they will be supported by better security in the days to come.

This upgraded is complete on all shared servers we operate.

Now what about those customers still running older versions of Joomla or Wordpress or other sites? We have taken this into consideration and as most shared hosting providers have provided backward compatability for all customers in cPanel itself.

This is how it works. All sites are automatically upgraded to PHP 5.4 by default. We have however installed a plugin that allows you, the customer, to login to cPanel and select 5.2 for any directory on your site. We will be adding a knowledgebase article sometime today to the client area with pictures and instructions on how to change this to 5.2 for any domain in your cPanel. But the gist of it is as follows:

Login to cpanel at: http://www.yourdomain.com/cpanel

Once inside scroll down to the bottom and find the icon for ntPHPSelector. Click this Icon. Once here click on the folder link for 'public_html'. This will bring up a screen with a dropdown. Click this dropdown and select 5.2. Then click on Submit.

Congratulations, your site is back to 5.2!

It's quite simple actually, but we will also be creating the knowledgebase article as well.

How do you know if your site needs 5.2? Please don't downgrade unless your sure you need it, as the security of 5.4 will no longer be there.

To know if you need 5.2 instead of 5.4 simply go to your site and view it using any web browser. If you see any error on it that does not look normal, then you probably need to downgrade.

For other customer that are on 5.4 and do not need to downgrade, please take comfort in knowing that although some customers are using 5.2 instead of 5.4 this in no way compromises the security of your site. All accounts are jailed accounts and cannot affect other accounts on the servers.

If you have any questions please feel free to open a support ticket and we will be happy to assist.

Regards,
Microtronix Administration

Thursday, May 8, 2014

« Назад

Powered by WHMCompleteSolution